Technology Made Simple
Monday April 24th 2017

Insider

Archives

Apple Releases Safari 5.0 and 4.1

safari_logo_3023 Now this may seem confusing there are two different versions of this update?  Well if you are someone who currently uses the Safari browser often but let me break this down for you as best I can…Safari 5.0 and Safari 4.1 address the same set of security issues, so if you don’t know which version you need just update your browser and your fine.. Safari 5.0 is what you have if you are on Mac OS X v10.5, Mac OS X v10.6, or Microsoft Windows systems. You’ll update to Safari 4.1 if you are on Mac OS X v10.4 systems.  Don’t know why they would make different versions, but they do.
Now that we got the whole version thing sorted out, here’s the nity grity of why you should be updating your browser.  Apple has released Safari 5.0 and Safari 4.1 for Windows and Mac OS X to address multiple vulnerabilities in ColorSync, Safari, and WebKit. These vulnerabilities may allow an attacker to execute arbitrary code, cause a denial-of-service condition, obtain sensitive information, or conduct
cross-site scripting attacks.
Needless to say like most other software it’s best to keep your browsers up to date to make sure they you minimizes the threat to your computer and your network.

TASER® StrikeLight™

Leave a Reply

Time limit is exhausted. Please reload CAPTCHA.